Swift badly needs to do something about its numeric types. Having to cast wildly between Double() and CGFloat() to do maths on coordinates or having to say DispatchTime.now() + DispatchTimeInterval.seconds(2) really doesn’t help DRY or readability.